Skip to content

View

The View menu contains commands for changing and creating view orientations, zooming, and assigning OpenGL settings.

img

imgimgimgimgimgimgimgimgimg

Redraw Screen

Refreshes the drawing window.

img

Right Side

The Right-Side option will change the view orientation to view the y, z plane looking down the x axis.

The view normal for this orientation is x = 1, y = 0, z = 0.

img

Front

The Front option will change the view orientation to view the x, z plane looking down the y axis. The view normal for this orientation is x = 0, y = -1, z = 0.

img

Top

The Top option will change the view orientation to view the x, y plane looking down the z axis. The view normal for this orientation is x = 1, y = 0, z = 0.

img

Left Side

The Left Side option will change the view orientation to view the y, z plane looking down the x axis. The view normal for this orientation is x = -1, y = 0, z = 0.

img

Back

The Back option will change the view orientation to view the x, z plane looking down the y axis. The view normal for this orientation is x = 0, y = 1, z = 0.

img

Bottom

The Bottom option will change the view orientation to view the x, y plane looking down the z axis. The view normal for this orientation is x = 0, y = 0, z = -1.

img

Isometric

The Isometric option will change the view orientation to view the x, y plane looking down the z axis. The view normal for this orientation is x = .577, y = -.577, z = .577.

img

Trimetric

The Trimetric option will change the view orientation to view the x, y plane looking down the z axis. The view normal for this orientation is x = .76, y = -.512, z = .39.

Navigator

The Navigator is a viewing tool independent of your drawing. The Navigator has two viewing modes: Sphere Mode and Step Mode. To toggle between the two modes, click the Step Mode or Sphere Mode button in the top right corner of the dialog.

img

Sphere Mode Step Mode

View

The Navigator dialog’s Views drop-down is available while in Sphere Mode, from the bottom right corner. It allows you to quickly choose one of the 8 saved views or choose DynView to drag the Navigator and set your view.

img

DynView

To activate DynView, use the Navigator to change your orientation. DynView also appears on the View drop-down. Each mode has rotation options which control the type of rotation and the origin of rotation.

img

DynView - Drop-down

Using the DynView setting you can manually control your view, either by dragging the Navigator in Sphere Mode or by clicking stepper controls to change your orientation in Step Mode.

To auto-rotate, click the Steps in the center of the Navigator while in Step Mode, then choose a direction. Your view automatically rotates in that direction until you click the Steps again.

Sphere Mode Rotation Options

In the top left corner of the Navigator dialog, click the Rotation Options button.

img

In Sphere Mode, Model is the only rotation type available. You can select your rotation’s point of origin by selecting either Model Point or Object Center. Using Model Point, you select a location on the design window or enter coordinate values in the text fields. Using Object Center, you select the object you want to use as your origin of rotation.

Step Mode Rotation Options

In the top left corner of the ViewBall dialog, click the Rotation Options button.

img

In Step Mode, you can select the rotation type, either Model or Screen. Model axis use the red/green/blue x, y, and z axis. Screen rotations are horizontal and vertical, relative to the monitor.

With Step Angle, you can define the increment that the object will rotate when you press the arrow keys

Using Model Point, you select a location on the design window or enter coordinate values in the text fields. Using Object Center, you select the object you want to use as your origin of rotation.

Save View

You can save views using the Navigator. From the Views drop-down, choose Save Current View. View The Plane

This option will change the view to that associated with the current work plane. The eye point is taken 500 units out along the work plane normal. The reference point is taken as the work plane origin.

Flip View

The Flip View command will change the current view by flipping the eyepoint to the other side of the view plane. Internally, the view normal changes the sign of its direction. For example, flipping the top view will yield the bottom view and flipping the front view will yield the back view.

Rotate View

The Rotate View command rotates the eye point 180 degrees about the up vector.

New View

The New View option provides a means to create custom user defined views. Options are described below.

img

ViewName

Assigns a user specified name to the particular view. This name appears in the drop-downs that identify the view.

Create by

A pull down menu that determines the method for specifying the eye point, reference point, and up vector. Methods exist for specifying these valuesas:

  • Eye Pt Reference Pt
  • Azimuth/Elevation
  • Rotation relative to current view

Perspective

Sets a flag indicating whether this view has Perspective enabled.

Field of View The Field of View entry is a value that represents the angular value associated with

the eye point, reference point, and viewable area. Small fields of view imply you are

far away from an object.

Focal Length The Focal Length is the distance between the eye point and reference point.

User Views This value is only used in perspective mod

The User Views Menu option provides a means to access user-defined views. When selected, a submenu will appear with all the user-defined views. Simply pick one and the current view is changed to the selected view.

Delete View

The Delete View command is used to delete user defined views. Select the view to delete from the submenu and the view will be permanently purged from the file.

Tip: There is no undo for this operation.

View Properties

The View Properties dialog box will display all relevant information associated with the current view. In the case of user defined views, you can use this dialog to modify values. The dialog displayed is the same used in creating new views.

Viewport Layouts

Viewports allow you to display multiple views of your drawing at one time, each with a different orientation. For example, you can view your design from the top, while also viewing the left side and an isometric view.

img

Viewport Layouts Menu

You can also see multiple views of your design simultaneously. In addition to the Viewport options available within the user interface, you can view a floating window, which you can move around your workspace.

img

Two Viewports Three Viewports Four Viewports

img

Four-Left 1/3 Viewports Four-Right 1/3 Viewports

Viewport Configurations

Viewing multiple Viewports

  1. From the View menu, choose Viewport Layouts and, from the submenu, choose the Viewport configuration you want.
  2. To change a Viewport’s orientation, click the current view, at the top of the Viewport, and from the pop--up menu that appears, choose the view you want.

Viewport Sizing

As you move your cursor over a viewport’s borders, the cursor will change indicating that it’s possible to drag the border to reshape and resize the viewport.

Shade Options

Clicking the label displays a drop-down with a list of options, including view orientations and shading.

img

You can customize each view’s shade options, so each orientation is easily recognizable.

img

Shade Options Menu

Viewport Options

Each Viewport also has its own Viewport Options, which can be set to further customize each view. Click Options from the Viewport drop-down menu to display the Viewport Options dialog.

img

Here you can set the orientation of the Viewport menu, as it appears in the Viewport. You can also customize the colors associated with the Viewport.

Zoom In

The Zoom In command will enlarge the current view by 20 percent.

Zoom Out

The Zoom Out command will decrease the current view by 20 percent.

Zoom Previous

The Zoom Previous command will restore the zoom scale to the previous zoom setting.

Zoom All

This command calculates the extents of your drawing and zooms to a size that will fit the drawing in the current window. Extents are only checked for objects blanked on and in the current display layer set.

Zoom Window

Zoom Window prompts the user to define a rubber banding box which is used to describe the extents of a new window. This command will always enlarge the view, independent of how you start your banding box.

Zoom Home

Zooms to the default view used at start up. The default view scale is defined the File: Preferences: General controls.

Zoom Ratio

Scales the view up or down by a specified amount.

Zoom Scale

Zooms the view to a specific scale between window and model space.

Zoom Select

Zooms the view to the selected entities (includes edges and faces).

Show Axis

Turns on or off the model coordinate system axis located at 0,0,0.

Show Triad

Displays a small model axis and work plane in the upper right corner of the window. The triad is useful for orientation independent of view scale or position.

img

Shade Now

The Shade Now option renders the screen using the current OpenGL settings. This option is useful if you normally work in wireframe mode and need to occasionally see the data in rendered mode.

Shade Options

The Shade Options dialog provides controls for display settings related to OpenGL.

img

Flip Normals

When this option is checked, surface normals are automatically flipped such that surfaces pointing away from the viewer are not dark. Otherwise surfaces are displayed only with ambient light.

Z-Buffer Curves

This option turns on or off OpenGL depth buffering of curves as they are displayed in context with surfaces and solids. With this option on, curves behind surfaces or solids are hidden and visible when turned off.

img

Show Facet Edges

The Show Facet Edges option turns on or off the edges of the display facets. The facet density is determined by the entity resolution.

img

Use Clip Planes

This option indicates whether to process clip planes for OpenGL rendering. When turned on, all planes entities that are marked as clip planes will clip the current view. To mark a plane as a clip plane, right click over the entity and select the appropriate option in the menu.

img

Backface Culling

Backface Culling is an option that greatly enhances OpenGL performance. When this option is on, OpenGL ignores all facets from solids that have normals facing away from the viewing direction. Turn this feature off if you have hybrid solids that mix open surfaces with solids, otherwise the surface may appear invisible in OpenGL display modes.

Anti-Alias

This option tells the OpenGL drivers to enable anti-aliasing of edges.

Clip at Eye Point

The Clip at Eye Point turns on or off clipping at the eye point. If off, clipping is automatically determined based on the extents of the given model.

Opacity

This option indicates whether to process objects marked with an opacity flag for OpenGL opacity. When turned on, all surface and solid entities that are marked as transparent will clip the current view. To mark an object as transparent, Control-click (right-click) an entity and select the transparent option from the menu.

The slider value indicates a global opacity setting. A setting of 100 implies no transparency and a value of 0 implies fully transparent.

img

Update Silhouettes

Turns off the calculation of silhouette edges when the view orientation is changed. By default, this is on.

Use Vertex Arrays

Uses the fastest path to OpenGL by sending vertex arrays to the graphics board. By default, this is on.

This feature uses more RAM then when disabled.

Level of Detail

Objects that are under a certain size with respect to the viewing area are displayed as boxes. These values range between 0 and 100 percent of the screen viewing area. Specify 0 to turn this feature off. The Static Level of Detail applies to repaints, zooming, changing view type operations. The Dynamic Level of Detail applies to dynamic zooming, panning, and rotating.

Ambient Light Settings

This setting affects the color and intensity of ambient light to all objects in your displayed scene

img

The Ambient Light dialog contains three sets of user controls described below:

Color

This control sets the color of the ambient light. You can adjust the color using Red, Green, and Blue sliders or select an existing color from the pull-down menu.

Intensity

The Intensity Slider controls the strength of the ambient light. A zero turns off all ambient light. Values greater than 5 will wash out the model.

img