Skip to content

Symbol Editor

A3D-UltimateA3D-Platinum PHD-Architectural-Series PHD-Professional PHD-Studio

This Software Symbol Editor lets you create custom symbols, or modify existing symbols, for use in your 2D drawing plans. Using standard 2D design tools, you can draw the symbol, save it to a library, and even record a brief description of the symbol. You can manage your custom symbols, and the entire library of This Software symbols, using the Symbol Organizer.

Launching Symbol Editor

  1. Click Design menu > Launch PowerTool. The PowerTool Launcher is displayed.
  2. Click to select Symbol Editor and click the Launch button. The Symbol Editor is launched.

Managing Symbols

Symbol Editor not only allows you to save new symbols for use in your 2D drawings, it also has easy-to-use tools for organizing symbols and managing symbol categories.

To save a new symbol

  1. Click the Add Symbol to Library button. The Save Symbol to library dialog box is displayed.

img

2- Symbol Category specifies the category where the symbol is saved. Click New to create a new category. Select a folder in which to create the new category, then type a name for the new category and click OK.

3- Symbol Name is the unique name for the symbol. Names can contain up to 44 characters.

4- Symbol Description is the description of the symbol. Descriptions can contain up to 78 characters.

5- Click OK to save the symbol.

Using 2D Drawing Tools to Draw Symbols

Symbol Editor features a full array 2D drawing and editing tools. You can create symbols from scratch with text or the drawing tools. Or you can create new symbols by adding geometry to existing symbols.

img

Tip: When drawing multiple instances of a CAD component, be sure turn off Auto Reset. When Auto Reset Tools is unchecked, you can draw concurrent CAD components without selecting the corresponding CAD tool each time. For more information see in the section “Controlling Drawing Settings”.

For more information on using drawing tools, see “Detail Plan Tab”.

Adding Text to Symbols

Use text to add information to your symbol. For example, you might specify a model number or a specific feature in your symbol. Symbol Editor gives you the flexibility to place text anywhere in your drawing, using different formatting techniques for each text instance.

For more information, see “Adding Text to Details”.

Using Rules and Fills

You can change the thickness (weight) of the lines or fills of the CAD shapes.

img

For more information, see “Draw Style Tab”.

Using Dimensioning Tools

The Leader Dimension Tool is available to help with precise drawing as you create symbols. For more information, see “Leader Dimension”.

Editing Symbol Editor Elements

You can move, rotate, and modify elements using the array of editing tools in Symbol Editor. The following options are available for editing your design:

imgSelection Tool (For more information, see “Moving a Selection” and “Reshaping and Resizing 2D Objects"

imgRotate Tool (For more information, see “Rotating a Selection”)

imgResize Segment Tool (For more information, see “Changing Segment Length”)

imgAdd Point Tool (For more information, see “Editing Detail Shapes”)

imgRemove Point Tool (For more information, see “Editing Detail Shapes”)

imgFillet Tool (For more information, see “Editing Detail Shapes”)

imgInverted Fillet Tool (For more information, see “Editing Detail Shapes”)

imgChamfer Tool (For more information, see “Editing Detail Shapes”)

To scale objects

img

  1. Click the Selection Tool and then click to select the element.
  2. Click the Resize Selected Tool. The Scale Selection dialog box appears. (alternatively) Click Options menu > Scale Selection.
  3. Choose either Object Size or Percentage, then enter values to scale the element.
  4. In the Scale From section, choose a location to use as the basepoint, during the scaling operation. For instance, clicking Bottom Right means that location will remain constant.
  5. Click OK.

To skew objects

  1. Click the Selection Tool and then click to select the element.
  2. On the Standard Toolbar, click the Skew Tool.
  3. Click a corner point of the element; hold down the mouse button and move the pointer in the direction that you want the element to be slanted. Dimensions appear in the position readout bar, as you draw.
  4. Release the mouse to stop skewing the element.

img

To trim objects

  1. Click the Selection Tool and then click to select the element.
  2. On the Standard Toolbar, click the Trim Tool.
  3. Click the point on the segment where you want to trim (or break) the element into two separate segments.

To join arcs, lines, or polylines

1- Click the Selection Tool, then hold down SHIFT and click to select each element that you want to be joined.

Note: The end points of each element must be nearby for those elements to be joined. You can increase or decrease the necessary distance by changing the Join Sensitivity, see “Controlling Drawing Settings”.

2- On the Standard toolbar, click the Join Tool. The elements are joined into a polyline.

Note: You can separate the segments of any polyline (whether or not you created it using the

Join Tool) by selecting the polyline and clicking the Unjoin Tool on the Standard toolbar.

To place an element on top of another element

  1. Click the Selection Tool and then click to select the element you want to place on top.
  2. Click the Bring To Front button. (alternatively) Click Arrange menu > Bring To Front.

To place an element behind another element

  1. Click the Selection Tool and then click to select the element you want to place on the bottom.
  2. Click the Send To Back button. (alternatively) Click Arrange menu > Send To Back.

To clear elements

Right-click the element and choose Clear from the context menu.

Flipping Elements

The Flip function takes the original element and reverses it either horizontally or vertically.

To flip horizontally

  1. Click the Selection Tool and then click to select the element you want to flip.
  2. Click the Flip Horizontal button. (alternatively) Click Arrange menu > Flip > Horizontal.

To flip vertically

  1. Click the Selection Tool and then click to select the element you want to flip.
  2. Click the Flip Vertical button. (alternatively) Click Arrange menu > Flip > Vertical.

Mirroring Elements

Mirror works similarly to the Flip function. The difference is that mirror leaves the original and makes a duplicate. Mirror creates two identical elements facing one another.

To mirror horizontally

  1. Click the Selection Tool and then click to select the element you want to mirror.
  2. Click the Mirror Horizontal button. (alternatively) Click Arrange menu > Mirror > Horizontal.

To mirror vertically

  1. Click the Selection Tool and then click to select the element you want to mirror.
  2. Click the Mirror Vertical button. (alternatively) Click Arrange menu > Mirror > Vertical.

Duplicating Objects

Similar to cutting and pasting, the duplicate feature creates an exact copy of the object you select. In the Duplicate Offsets dialog box, you can specify the number and specific offset of a series of duplicates.

To create a duplicate

  1. Click the Selection Tool and then click to select the object you want to duplicate.
  2. Click Edit menu > Duplicate Object (or press CTRL+D).

To create a series of duplicate objects

1- Click the Selection Tool and then click to select the object you want to duplicate.

img

2- Click Edit menu > Duplicate Offsets. The Duplicate Offsets dialog box is displayed.

img

3- Type the horizontal and vertical offsets and the number of duplicates.

Note: These variables control the distance apart that the duplicates are placed.

4- Click OK. The object is duplicated at the offset you defined.

Grouping Elements

By defining a Group, you create a set of selected elements that are then treated as one item. You can have unlimited groups in a drawing.

To control groups

  1. Press and hold SHIFT and then click each element that you want to be included in the group.
  2. On the Control toolbar, click the Group Tool. The selections are grouped as one element.

Click the Ungroup Tool to ungroup a set of elements.

(alternatively) Click Arrange menu > Group or Ungroup.

Locking Elements

You can protect CAD components or symbols from accidental modifications by locking them. You can have unlimited locked elements in a drawing.

To control locks

  1. Click to select the element you want to edit. (optional) Hold down SHIFT and click to select multiple elements.
  2. On the Control toolbar, click the Lock Tool to lock the selection(s) in place.

Click the Unlock Tool to unlock the selection(s). (alternatively) Click Arrange menu > Lock or Unlock.

Controlling Drawing Settings

There are a variety of tools that allow you to control how you draw, select, or modify CAD components and symbols. The Preferences dialog box lets you modify a variety of settings, including the number of sides on a multigon or the sensitivity of snap or join tools.

Tools along the bottom of the drawing window allow you to draw parallel segments, switch between object and point selection modes or center and corner drawing modes.

Drawing Preferences

Drawing preferences are default settings that affect all tools and elements as your draw. These settings are controlled in the Preferences dialog box.

img

  1. Multigon Sides controls the number of sides on a selected multigon and changes the number of sides with which multigons are drawn.
  2. Curve Smoothness defines the default curvature. Lower values result in less curvature.
  3. Zoom Percentage defines the amount of magnification that is applied each time you click the Zoom Tool.
  4. Scrolling Speed allows you to increase or decrease the rate at which the drawing window moves when you click the scroll arrows.
  5. Snap Tool & Selection Sensitivity allows you to increase or decrease the snap radius. A lower value means that you must click closer to an element to snap to or select it.
  6. Join Sensitivity allows you to Increase or decrease the join radius. A lower value means that you must position elements closer to join them.
  7. Auto Reset Tools checkbox controls tool behavior. When deselected, you can draw concurrent CAD components without selecting the corresponding CAD tool each time; when selected the tool resets to inactive after you use it.

To change drawing preferences

  1. Click Options menu > Preferences. The Preferences dialog box is displayed.
  2. Edit the preferences you want and then click OK.

Drawing Scale

The drawing scale defines how the details on the screen relate to the actual size. When adjusting the drawing scale, you can choose to update existing elements in your design by rescaling them to reflect the new scale.

img

  1. Screen Units defines the size of the objects on the screen that correlates to a real-world size. Higher values in the screen units section make it easier to draw small details.
  2. World Units defines the actual size of objects in the real world that correlates to the screen size. Higher values in the world units section make it easier to draw large details.
  3. Rescale Objects checkbox updates existing objects to the new scale when selected; when deselected existing objects are unaffected by changes to the scale.

To change the drawing scale

  1. Click Project menu > Drawing Scale. The Drawing Scale dialog box is displayed.
  2. Edit the scale units and settings as needed and then click OK.

Paper Size

The drawing area is determined by the paper size setting. Depending on your needs, you can adjust the paper size so your design is created on a realistic page. You can choose one of the four output styles, then select a standard size from the corresponding drop-down menu or choose to define a custom size.

img

To change the paper size

  1. Click Project menu > Paper Size. The Paper Size dialog box is displayed.
  2. Choose an output style and size or choose Custom and define the width, height, and unit of measurement.
  3. Click OK.

To display the drawing pages

Click Project menu > Draw Page Breaks. When a checkmark is visible page breaks are enabled

Drawing Origin Position

By default, the drawing origin is positioned at 0,0. You can change the position of the origin by selecting a point or by manually defining its position along the horizontal and vertical axis.

To display the drawing axis

Click Project menu > Draw Axis. The axis lines are dotted lines drawn through the origin. When a checkmark is visible the axis is visible.

To set the drawing origin by clicking a point

Right-click in the drawing area where you want the origin and choose Set Origin from the context menu. The origin is repositioned to that point.

To move the drawing origin by defining X and Y

  1. Click Project menu > Move Origin. The Move Origin dialog box is displayed.
  2. Type a new value in the Horizontal and Vertical text boxes and then click Move. The drawing origin is moved by the horizontal and vertical increment you specified.

img

(optional) Click Reset to reset the origin to 0,0.

To change the axis color

img

  1. Click Project menu > Axis Color. The Color dialog box is displayed.
  2. Click an area on the color spectrum window to select a color, then adjust the values, if necessary. (optional) Adjust the current Red, Green, and Blue values to create a custom color.
  3. Click OK. The color you defined is applied to the axis.

To change the drawing color

  1. Click Project menu > Drawing Color. The Color dialog box is displayed.
  2. Click an area on the color spectrum window to select a color, then adjust the values, if necessary. (optional) Adjust the current Red, Green, and Blue values to create a custom color.
  3. Click OK. The color you defined is applied to the drawing.

To change the background color

  1. Click Project menu > Background Color. The Color dialog box is displayed.
  2. Click an area on the color spectrum window to select a color, then adjust the values, if necessary. (optional) Adjust the current Red, Green, and Blue values to create a custom color.
  3. Click OK. The color you defined is applied to the drawing background.

Drawing Parallel Segments

img

You can draw one or more parallel segments for any CAD component. Use the Parallel dialog box to specify the number of parallel segments, as well as their distance and direction from the original.

  1. Inside, Outside, and Center specify the direction for the parallel segment.
  2. Parallel Width defines the distance between the original and parallel segments.
  3. Group checkbox allows you to automatically group the original and parallel segments. When selected, the segments are grouped; when deselected they are not.

To control the settings for parallel segments

  1. Click Options menu > Parallel. The Parallel dialog box is displayed.
  2. Choose a direction to draw the offset parallel and then type a new value in the Parallel Width text box. This controls the distance between the original and parallel segments. (optional) Select the Group checkbox to automatically group the original and parallel segments.
  3. Click OK.

To enable/disable parallel segments

  1. Click Turn On Draw Parallel in the lower left corner of the window. When a single line is visible parallel segments are disabled.
  2. Click Turn Off Draw Parallel in the lower left corner of the window. When a double line is visible parallel segments are enabled.

Using Object or Point Selection Modes

Object Selection Mode is active by default. Object selection, along with point selection, controls how your edits impact your object. If you are in object selection mode, changes affect the object as a whole. If you are working in point selection mode, each edge of the object is treated separately, as you edit.

In point selection mode, you are able to resize or reshape an object by moving one of its individual points. While it is easy to move an entire object in object selection mode, it is much more convenient to handle detailed edits using point selection mode.

For more information, see “Controlling Selection Mode”.

Drawing from Corner or Center

You can draw a CAD component from corner to corner or from center to corner. Draw from Corner makes drawing cabinets, tables, and most other angular elements much easier. Draw from Corner works with the rectangle, oval, and line/plane tools only. For more information, see “Drawing from Corner or Center”.

Changing Curve Tension

To further control the look of the shapes drawn with any of the arc or curve tools, you have control over the degree of curve assigned to them. With the Unsmooth feature it is easy to create angular shapes and with Curve Tension you can change the appearance. Curve Tension is measured between 1 and 20. Specifying 1 in the dialog box results in very little tension being applied, while specifying 20 is the maximum amount allowed and causes a greatly- exaggerated curve.

For more information, see “Changing Curve Tension”.

To change curve tension

img

  1. Click an element to select it.
  2. Click the Smooth/Unsmooth Selected button then click Smooth. The Tension dialog box is displayed. (alternatively) Click Options menu > Tension.
  3. Type the amount of tension that you want and then click OK. The Curve Tension you specified is applied.

Changing Grid Settings

img

By default, the grid is visible and set at twelve inches. This way you can visualize that each large square in the Design window is one (1) square foot. By customizing the grid, you can design to fit your specific needs. In addition, by turning the Snap Grid on and off, you will be able to make detailed placement of the symbol components simple.

For more information, see “Using the Grid”.

To control grid visibility

Click the Grid On/Off Toggle at the lower left of the window or on the Project menu,

click Grid, Grid Visible. If Grid Visible is checked it is displayed. If unchecked, the grid is hidden from view.

To turn off the snap grid

Click the Snap Grid On/Off Toggle at the lower left of the window or on the

Project menu, click Grid, Snap to Grid. If Snap to Grid is checked, Snap to Grid is on. If unchecked, Snap to Grid is off.

To change the grid color

  1. Click Project menu > Grid Color. The Color dialog box is displayed.
  2. Click an area on the color spectrum window to select a color, then adjust the values, if necessary. (optional) Adjust the current Red, Green and Blue values to create a custom color.
  3. Click OK. The color you defined is applied to the drawing grid.

Using Snaps to Draw CAD Components

This Software includes the power of snaps. With snaps, you can define exactly what distance CAD components are placed from other CAD components. You can TAB through the Snaps Toolbar. Each time you press TAB, the next Snap Tool is activated, SHIFT+TAB reverses the process.

Note: Each Snap Tool defaults back to “No Snap” after it is used; double-clicking the Snap Tool will lock it in active mode.

For more information, see “Using Snaps to Draw Components”.

To snap a CAD Component to the drawing origin

  1. Click one of the CAD tools.
  2. On the Snaps toolbar, click the Snap to Drawing Origin Tool, or press TAB to move through the tools on the Snaps toolbar.
  3. Click in the design window. The CAD component will “snap to” the drawing origin.

Note: For information on moving the drawing origin, see “Controlling Drawing Settings”.

Viewing your Drawing

The Symbol Editor supports the same zoom and pan capabilities you can use when viewing your design in 2D.

For more information, see “Zooming In and Out in 2D”,“Panning Across the 2D Drawing”.

Exporting and Importing

There may be times that you want your symbol exported to DXF/DWG format.

To export a DXF/DWG symbol

img

  1. Click File menu > Export DXF/DWG. The Export Options dialog box is displayed.
  2. Choose a format and a version for your file.
  3. You can include Colors, and Fills / Patterns by checking these options.
  4. Click OK. The Export DXF/DWG dialog box is displayed.
  5. Type a file name in the File Name text box. Symbol Editor automatically adds the extension.
  6. Click Save.

To import a DXF/DWG symbol

img

  1. Click File menu > Import DXF/DWG. The Import DXF dialog box is displayed.
  2. Find the file you want to import and then click to select it. (optional) Select the Group Objects on Import checkbox to group all elements in the DXF/DWG together.
  3. Click Open. The Scale menu is displayed.

img

4- Choose the scale you want to use and then click OK.

5- You can explode blocks, and use the geometry colors by checking these options