Skip to content

Tables

(Available in all TurboCAD Variants)

Default UI Menu: Draw/Table

Ribbon UI Menu:

img

Insert Table enables you to insert an empty table, and Modify Table enables you to add or edit text in the table. Insert Table is available on the Draw menu, and Modify Table is available on the Modify menu. Both tools are also available on the Text toolbar. You can display the Text toolbar by right-clicking on any toolbar area and selecting Text. img

Changing Rows and Columns, Merging Cells

Other than adding text or changing individual cell properties, which are done using the Modify Text tool, table changes are made with the Edit Tool.

Note: For details on the Edit Tool .

  1. To start editing, activate the Edit Tool and click the table. You can move any of the nodes to change sizes of single rows or columns.

img

  1. To add a row or column, press Shift and click the cell to the left or above where the new item will go.

img

Note: If you want to Shift-select a new cell, you must first use Shift and click to de-select the current cell.

  1. Insert Row and Insert Column are available on the local menu or Inspector Bar.

img

The new row is added below the selected cell.

img

  1. To remove a row or column, Shift-select a cell in that row or column.

img

The row is removed.

img

  1. To merge cells, Shift-select each cell you want to merge.

img

  1. Select Merge Cells in the local menu or Inspector Bar.

img

The selected cells are now one cell.

img

  1. To separate them again, Shift-select the cell and select Unmerge.

Local Menu & Keyboard

The local menu provides additional controls and lists the complementary keyboard commands for those functions. You can change and expand or contract the cells which are selected. most importantly you can opt to edit the cells text or block. img

Insert Table

‚Äč img

Default UI Menu: Draw/Table/Table

Ribbon UI Menu:

img

Before creating a table, you can define a table style . Styles are useful for creating tables with specific text properties, cell colors, and header / title rows.

img

To apply the style to the table, open the tool's Properties and select the style on the General page.

img

You can also change an existing table's style in is Properties, or in the Selection Info palette. There are two methods of inserting a table: Specify Insert Point and Specify Window.

Specify Insert Point

With this method, you click the top left point of the table.

  1. Make sure Specify Insert Point is selected in the local menu or Inspector Bar. The number of columns and rows, as well as column width and row lines (number of lines of text) is set in the Inspector Bar.

img

  1. Click once in the file, and the table is inserted.

img

  1. If you don't want to insert another table, press Esc or start a new tool.

  2. If you need to change the size of an individual row or column, use the Edit Tool.

Specify Window

With this method, you insert the table by clicking two corner points. You can either fix the cell dimensions, or you can fix the number of rows / columns. (You can also mix options for sizing and numbers for rows and columns.) Make sure Specify Window is selected in the local menu or Inspector Bar.

img

Fixed Number of Rows - Columns

  1. Activate both Calculated Row Height and Calculated Column width.

img

  1. Click once to set the top left corner of the table.

img

  1. Set the number of columns and rows.

img

  1. Move the mouse to size the table.

img

The number of cells remains the same, no matter how the table is sized.

img

  1. Click the second corner to insert the table. If you specified a table style, it will be applied.

img

  1. If you need to change the size of an individual row or column, use the Edit Tool.

Fixed Cell Size

  1. Turn off both Calculated Row Height and Calculated Column width.

img

  1. Click once to set the top left corner of the table.

img

  1. Set the column width and number of text lines per row.

img

  1. Move the mouse to size the table.

img

The cell size remains the same, no matter how the table is sized. Cells are added or removed as needed.

img

  1. Click the second corner to insert the table. If you specified a table style, it will be applied.

img

  1. If you need to change the size of an individual row or column, use the Edit Tool.

Modify Table

Default UI Menu: Draw/Table/Modify Table

Ribbon UI Menu:

img

Modify Table is used to add text to cells, or to edit existing cell text. It can also be used to change properties of individual cells.

Adding or Editing Cell Text

If you are using styles, the table style will refer to a text style for each type of text (data, header, and title). So unless you want to use standard text, define text styles first.

img

Note: For details on text styles.

Open the table style you want to use, and specify the text style you want to use for Data text. You can also set text color and height here.

img

There are also categories for Header and Title, which can each have their own text style.

img

  1. To add text to the table, activate Modify Table.

  2. Make sure Edit Cell Text is active in the local menu or Inspector Bar.

img

  1. Select the table you want to modify, then click in a cell where you want to place text.

img

  1. Click in each cell and select Edit Text from the Inspector bar or Local menu. Then type the text.If your drawing has blocks use Insert block you can also opt to insert a block into the cell.

img

  1. If you want to remove text from a cell, click it and select Clear Cell Content from the local menu or Inspector Bar.

img

  1. When the table text is complete, end Modify Text. The properties of the cell text will match their text styles.

img

Changing Cell Properties

  1. If you want to use Modify Text to change properties of an individual cell, make sure Edit Cell Text is not active.

img

  1. Click the cell you want to change.

img

  1. The properties of the cell can be changed in the Selection Info palette. In this example, the cell's fill color was changed.

img

  1. When finished, the cell has the new properties.

img

Text Rotation:

TurboCAD table now supports the "Text Rotation" property. Now table cell has editable property - Text Rotation.

Also, cell editing has been improved. Now the cell selection in not lost after changing the properties of the cell using the "Selection Info Palette".

img

Table Export (*.xlsx)

Default UI Menu: Draw/Table/Table Export

Ribbon UI Menu:

img

This tool allows you to save a table as an Excel (.xlsx) file. To save a XLSX file:*

  1. Select the tool.

  2. Click on a table.

img

  1. Type in a File name.

img

  1. Click the Save button.

  2. Press the Space bar to finish.

Table Import (*.xlsx)

Default UI Menu: Draw/Table/Table Import

Ribbon UI Menu:

img

This tool enables you to create a table based on a sheet from an Excel (.xlsx) File. To Create a Table*:

Start the too and the dialog appears.

Click the down arrow in the Choose an Excel Data Link dropdown.

img

Click on Create New Data Link.

Type in a name and click OK.

img

Click the down arrow in the Choose an Excel file dropdown.

Click on Browse for a new Excel (*xslx) file.

img

Select a file.

Click Open.

Click the down arrow in the Select Excel sheet to link to dropdown.

img

Select a sheet.

img

Click OK.

Position the cursor and click to insert the table.

img

The dialog will reopen.

img

Change the parameters and insert another sheet, or click Cancel to terminate the operation.

To Delete a Data Link

  1. Click the down arrow in the Choose an Excel Data Link dropdown.
  2. Select an existing link.
  3. Click the Delete button.