Skip to content

Blocks

(Available in all DoubleCAD Variants)

One or more objects can be combined and stored as a block. A block is treated as a single object for purposes of selecting and editing. Each block is stored in the drawing's internal library, and each instance of the block is a reference to this source. This means that numerous instances of a block can be added to the model without significantly increasing the file size. Groups are similar, but they are not linked to sources; each group contains its own drawing data. See Groups

Note: A drawing's block library is internal to the drawing, and is stored with the file. Symbol libraries are similar but are stored separately, and can be accessed while in any drawing. If you need to create a group of objects that will be used in multiple drawings, create a symbol. See Loading Symbol Folders into the Library.If you want to import the entire contents of another file (DoubleCAD or other format) as a block, see External References

Because blocks can contain individual objects, groups, and other blocks, they can be complex hierarchical structures. For block manipulation, use the Blocks Palette (View / Blocks).

Tip: You can use the DoubleCAD 6 Explorer Palette to view blocks of any open drawing, and to drag blocks to and from drawings. See Drawing Settings

You will find details on using block and the Blocks palette on the following pages:

Additional Block Controls

img

Show Selected: Toggles the Show Selection option. When on the result will be that anytime a single block is selected int the drawing space, that block will be selected and highlighted in the Blocks palette.

img img

Block name prefix: If names are automatically generated, you can enter a string that appears before the item name. The "@" character is a placeholder for the automatic number. Prompt for name: You will receive a prompt each time a new item is created. Generate block names: Names will be automatically assigned. Insert blocks when creating: Each block will be inserted into the drawing once it is created. Compensate for the offset of the base point at the block references: Prevents updating of the reference points for inserted blocks, when a the block reference point is relocated.Editing a Block Show Selection any time an inserted block is selected: Toggles the Show Selection option. When on the result will be that anytime a single block is selected int the drawing space, that block will be selected and highlighted in the Blocks palette.

Block Attributes

img

Default UI Menu: Draw/Block/Block Attributes

Ribbon UI Menu:

imgA block attribute is AutoCAD- informational text associated with a block, that you can enter whenever you insert a block. DoubleCAD reads and displays block attributes from AutoCAD drawings (DWG) and DXF files.

\1. Create the objects that comprise the blocks.

img

(You can also add a block attribute after a block has been created, in Edit mode. This is done the same way as adding another geometric object. See Editing a Block.)

\2. Select Block Attribute Definition. Select the start point for the text, preferably on or near the block objects.

\3. Type the "tag" name for the block attribute, such as "COST." This name is used to uniquely identify the attribute within the block, since more than one attribute can be created. If the drawing will be sent to AutoCAD, do not use spaces (use underscores instead).

img

Note: This tool works like the text tool, in terms of alignment and local menu options. See Inserting Text

\4. Enter the prompt and default value in the Inspector Bar, or you can enter these properties later. For example, the Prompt can be "How much does it cost?" and Default can be $0.00.

img

\5. Press Enter to finish the definition. You can create multiple attributes, such as Part Number, Owner, etc.

Once the block attribute is created, you can open its Properties to add or change the Tag, Prompt and Default values, as well as Mode.

img

Mode: Affects how the dialog appears when the block is inserted: Invisible: The text of the block attribute is not displayed in the drawing. You can see the information in the Selection Info Palette or edit it by displaying the block's properties.

Warning: When you explode a block containing invisible block attributes, the information is lost.

Constant: The attribute value is fixed and unchangeable. It is shown to you during block insertion. Exploding the block will turn the block attribute into text that can then be edited. Verify: Prompts you to verify that the attribute value is correct when you insert the block. In AutoCAD, the attribute value is shown for your verification during block insertion if the AutoCAD variable ATTDIA is set to 0. This flag has no effect in DoubleCAD as it takes place in AutoCAD when the variable ATTDIA is set to 1. Preset: Sets the attribute to its default value when you insert a block containing a preset attribute. In AutoCAD, you are not prompted for a value if the AutoCAD variable ATTDIA is set to 0. This flag has no effect in DoubleCAD as it takes place in AutoCAD when the variable ATTDIA is set to 1. When the block attributes are defined, simply include them in the selection of objects that will make up the new block.

img

Setting Block Attributes

When you insert a block that has one or more attributes, a window will appear that gives the prompt and offers the default value. For example, the prompt says "What does it cost?" the default value is $0.00. The value can be changed to another value, in this case, $3.50.

img

For multiple attributes, use the Next and Previous buttons to set values for all of them. When the block is inserted, the value is included with the objects.

img

When a block has attributes defined, its Properties will contain an additional page - Block Attribute. You can edit each attribute value in this window, using the Next and Previous buttons to scroll through multiple attributes.

img

Sync Attributes

Sometimes it is necessary to add attributes to blocks after many instances of the blocks have already been inserted into the drawing. In this case the new attributes are not automatically added to the prior insertions. The Sync Attributes button will add the new attributes to the older blocks.

img

The values for these newly synced attributes within the older blocks will be the default value you assign to the attribute when you create it and it will blank if no value is assigned. For blank attributes you will have to select the existing blocks and assign values to those attributes.

Extracting Block Attributes

If you attach attributes to blocks, you can extract these attributes and display them in a table. You can also export the attributes to a report in an external file.

Note: If you want to create a schedule for architectural elements in your file (walls, slabs, windows, or doors), without defining block attributes, see Schedule Styles

This example has three blocks used to mark windows, doors, and slabs.

img

Here are the three blocks in the Blocks Palette.

img

\1. Select Extract Attributes. In this window you can select the blocks and attributes that will be included in the schedule or report.

img

Note: You can re-order a a column by dragging its header to the new location. Scan Entire Drawing: Attributes will be extracted from all paper spaces and model space.

Scan Model Space: Attributes will only be extracted from model space.

Scan Current Space: Attributes will be extracted from the current model space or paper space.

Scan Selected Entities: Attributes will be extracted only from currently selected objects.

Scan Groups: If any groups contain blocks, these blocks will be scanned for attributes.

Scan Nested Block: If blocks contain nested blocks, these nested blocks will be scanned for attributes.

Include Xrefs: The content of Xrefs will also be scanned. The Blocks list contains all blocks that have attribute definitions. The Properties list all attributes found for the blocks checked in the Blocks list.

Show Summary List: The Properties list contains all attributes for all blocks checked in the Blocks list.

Show Selected Block Properties: The Properties list contains attributes only for the block that is currently checked in the Blocks list.

Show Visible Properties Only: If selected only attributes that are visible will be shown.

\2. You can select attributes for each block that will be included. For example, click Show Selected Block Properties at the bottom, and select the "Door Mark" block. Check only the "COST" and "TYPE" attributes.

img

\3. Select the "Room" block and check "AREA," "COST," and "TYPE."

img

\4. Select the "Window Mark" block and check "COST" and "TYPE."

img

You can right-click on any field under Blocks or Properties to get a popup menu in which you can check or uncheck all, or change the display name.

img

\5. When the blocks and properties are defined, click Next.

img

DoubleCAD scans the file, and the Preview window displays the results.

img

If DoubleCAD Table is checked, the report will be inserted into the file. If you want to export the results, click External File. You can click on any column header to change the sorting order, or hide or rename a column.

img

\6. Click Finish. If the table is to be inserted into DoubleCAD, you will see the Insert Table window. Here you can define the column and row sizes.

img

\7. Click OK, and then click where you want to place the table.

img

You can make changes to the table formatting in the Selection Info palette.

Creating a Block

img

Default UI Menu: Format/Make Block

Ribbon UI Menu:

img

Combines all selected objects into a block. Objects can include drawing objects, images, OLE objects, groups, and other blocks. Blocks can be comprised of 2D and 3D objects.

Warning: You should move all objects to be used in a block to Layer 0, before creating the block. Many features will not work properly otherwise.

\1. Create the objects you want to combine into a block. Each object is separate, as you can see in Select mode.

img

You can set the reference point of the objects before creating the block or you can change it later.

\2. Select the objects you want to include in the block.

\3. Click Create Block.

\4. If auto-naming is not used, you must assign the block name.Check Insert at current location to create the block in place. Otherwise, the block will be removed from the drawing and stored in the library for future insertion.

img

\5. The block is created. If the block is inserted in the drawing, you can select it as one object.

img

Blocks are created on Layer 0, even if their components are on other layers. To insert the block, see. If you open the Blocks Palette, you can see each block you have created. You can also add blocks to the drawing, edit blocks and create new blocks using this palette.

img

Warning: Do not include lights in a block. If you do, the lights will remain in their original locations regardless of where you place the block in your drawing.

Creating a Block by Drag and Drop

To create a block this way, the Blocks Palette must be open. Select Blocks palette, or the Blocks Palette tab.

\1. Select the objects that you want to combine into a block. Click and hold the reference point (the yellow circle). The cursor turns into a double arrow.

img

\2. Drag the objects into the Blocks Palette. If auto-naming is not used, assign a block name.

\3. The block appears in the Blocks Palette.

img

Editing a Block

(Changing a block's contents) You can use any editing or node editing tool to modify, move, copy, add, etc. objects that comprise a block. This example use the block shown below, consisting of four objects. The block name is "Logo."

img

\1. In the Blocks Palette, select the block, and click Edit Content.

img

\2. In edit mode, the screen contains only the block components, which are available for editing. You can add, delete, or edit objects. Whatever appears on the screen will become part of the edited block.

img

\3. When finished, right click and select Finish block/group editing, or click Finish Edit Content in the Blocks Palette.

img

The icon for the block is updated to reflect the edited components. Any instances of the block already in the drawing are updated, including resized and scaled blocks.

img

when a block is edited, an editing mode indicator bar is displayed.

img

When block editing is done, click "Finish to Edit Block" in the indicator bar.

Relocating a Block Reference Point

Hotkey: Ctrl+Shift+R

img

A block is inserted by placing its reference point. By default, the reference point is at the center of extents of the entire block, but this location can be changed.

\1. In the Blocks Palette, select the block, and click Edit Content.

img

\2. Activate Relocate Block Ref Point. The default reference point appears, as a yellow circle.

img

\3. Click to specify the new location for the reference point.

img

\4. Select Finish to Edit Block, or click Finish Edit Content in the Blocks Palette.

img

Now when you insert the block by dragging, you will drag it by the new reference point.

img

Note: For any instance of a block you can move its reference point and rotation bar. However, this change only affects the block itself and any copies of it. New instances of the block will use the block's defined reference point.

Changing a Block Name and Description

\1. To change a block name or add a description, double-click the block icon in the Blocks Palette.

img

\2. Make the necessary changes in the Edit Block window.

img

\3. After the changes are made, any description you add will be displayed as a tool tip on the block icon.

img

Copying a Block

This section is on copying a block to create a new block. To create copies of the same block in the drawing, you can use any of the standard editing tools.

\1. To copy a block, select it in the Blocks Palette and click Copy.

img

\2. Depending on the Auto-Naming settings, a copy will be created with a generated name, or you will be prompted for a name.

\3. The new block appears in the Blocks Palette, and can be edited like any other block.

img

Deleting a Block

img

Press Delete a Block button. Remove block with all references: Deletes the block and all instances. Be careful when using this option, because it cannot be undone.

Replacing Blocks

One convenient feature of blocks is that they can easily be replaced by other blocks. You can replace all blocks in the drawing, or just selected blocks.

\1. To replace instances of a block, select the block in the Blocks Palette and click Replace References.

img

\2. In the Replace Block Reference window, select the replacement block. You can also choose to replace all instances in the entire drawing, or just those in the active space (visible).

\3. Click OK to implement the change.

To replace an instance of a single block, open its Properties to the Block Insertion page. Use the Replace with button to replace it with another block.

Exploding a Block

Click the Explode icon.

img

If you explode a block that contains nested groups or blocks, the nested groups will remain intact. Each sub-block must be exploded separately.

In Place Editing of Groups and Blocks

You can edit groups or blocks in place within the drawing.

\1. Select the block or group.

img

\2. Right click to open the local menu and select Edit tool.All other elements in the drawing will fade-out, while the selected entity remains clear.

\3. Proceed by making you desired changes to the object.This can include changing properties, moving geometry, adding geometry, editing geometry, and deleting geometry.

\4. If you are editing a block, other instances of the block will show the changes you are making simultaneously.

img

\5. To finish, right click and select Finish block/group editing, from the local menu, or Finish Edit Content from the Block Palette toolbar, or Finish to Edit Block/Finish to Edit Group form the Tools menu.

Block attributes that are edited, added or deleted will not be updated in exiting block insertions, including the one that you selected. Only the "Original" block in the palette will reflect attribute changes. As of DoubleCAD latest version, you can now snap to objects outside the block or group while in block/group mode.

Inserting a Block

To insert a block into the drawing, simply drag it out of the Blocks Palette and drop it into your drawing. The inserted block will still be selected after you place it, so that you can move, scale, or rotate it. s Blocks are placed on Layer 0, even if their components are on other layers. Layer 0 should always be left visible, or blocks will instantly "disappear."

Tip: You can use the DC Explorer Palette to drag blocks to and from drawings.

Block Insertion Properties

These properties can be used if you want to change any aspect of the block instance - its location, scale, angle, or the block reference itself. For any block, open the Properties window and open the Block Insertion page. For example, a block was inserted, then moved, rotated, and resized.

img

Its Block Insertion page contains the current values for Position, Rotation, and Scale.

img

You can change the values in this window, or use the Select Edit tools and see the updated values in these fields. To replace a selected block with another block, select the replacement block from the list and click Replace with. Click OK to implement the change.

Inserting Blocks into Another File or Application

You can also use the drag-and-drop technique to insert blocks into another open file. Dragging a block into another drawing accomplishes two things: it inserts the block into the target drawing, and it places the block into the library of the target document. The target drawing must be open and its window must be visible on the screen. (Use Window / Tile to see all open windows.) After you drag the block, the target file becomes the active window. Drag-and-drop can also be used to place blocks, symbols, or any selected objects into other Windows applications, such as Microsoft Word or graphics programs.

Note: You can also use File / Extract To to export all blocks into another file.

Inserting Blocks from Another File

The Insert / File tool can be used to insert some or all blocks from another file into the current drawing . If both drawing have blocks with identical names, you can choose whether to ignore or replace them.

Tip: You can also use File / Extract From to insert selected components like blocks (or layers or other settings) from another file into your drawing. However, this method will insert all blocks, without enabling you to pick and choose.

  1. Select Auto Naming and make sure that Prompt for Name is checked for Blocks.
  2. Select Insert / File and choose a file containing one or more blocks you wish to insert.
  3. Use the Add Blocks window to select the blocks to import:

img

The left panel displays the blocks found in the selected file, and the right panel displays any blocks that exist in the current drawing. Select the mode (Add, Replace, or Ignore) and click the relevant button at the top right (Add, Add / Replace All, etc.) to generate the blocks. If you want to pick and choose the blocks to add, make sure Process all additional blocks is not checked. Generate name: Assigns a new name to a block you wish to add. Modes: The options here depend on the selected block, and whether a block with the same name already exists in the current drawing. Add block(s): Adds the selected block. Replace block(s): The blocks from the external file will replace those in the current drawing. Ignore block(s): Click Ignore All and the blocks will not be added.

Options

Process all additional blocks: Adds and/or replaces all blocks found in the source file. Generate block name with prefix: Assigns a name automatically, with the specified prefix, to the inserted blocks. Using Insert / File also adds all drawing objects found in the source file. However, you can press Undo (Ctrl+Z) immediately after using AddBlocks to clear the imported objects, leaving only the imported blocks. You may have to undo twice, to remove objects both in Model Space and Paper Space. Other source file components like layers, lights, and views will also be inserted, but they can be deleted manually if needed.

Warning: If the source file and current drawing have layers or other components with identical names, the layers will be replaced with those of the inserted file.

There are other ways to import blocks from another drawing, without importing other components: Open both the source file and new file, and select Windows / Tile so that you can see both drawing windows. Use the Blocks Palette to drag blocks from the source file to the new file. This method imports the blocks only. In the source file, select the blocks you want to export (select in the drawing area, not in the Blocks Palette). Copy the blocks (Ctrl+C or Edit / Copy), and paste them (Ctrl+V) into the destination file. The AddBlocks window will appear. This method imports both the blocks and the layers the blocks are on.

By default, each new group, block, or symbol is assigned a name automatically. These names are numbered, and the number increases by one whenever you add a new group, block, or symbol to the drawing, ensuring that each has a unique name. By default, the generated names are "Group 1", "Group 2", "Block 1", "Block 2", "Symbol 1," "Symbol 2," and so forth. You can change the default naming settings in the Auto-Naming page of the Program Setup The "@" symbol is a placeholder where the actual number will be inserted. For example, if you type "Part @" in the Group name prefix field, the first group you create will automatically be named "Part 1", and the next group will be named "Part 2". If the Group name prefix is "#@ gear," the groups will be named "#1 gear," "#2 gear," etc.

Note: The first '@' that you include in the name is a placeholder for the automatic number. Any '@' characters that occur after the first one will be part of the actual name.

The name of a group or symbol (not a block) is listed on the General page of the Properties window, in the Attribute field. You can use this field to change the name (or path, for a symbol).

(Available in all DoubleCAD Variants)

Groups, blocks, and symbols are features that enable you to combine and store multiple objects for easy access, and for additional and future use.

(Available in XT Pro)

Default UI Menu: Draw/Table

Ribbon UI Menu:

img

Insert Table enables you to insert an empty table, and Modify Table enables you to add or edit text in the table. Insert Table is available on the Draw menu, and Modify Table is available on the Modify menu. Both tools are also available on the Text toolbar. You can display the Text toolbar by right-clicking on any toolbar area and selecting Text. img

Changing Rows and Columns, Merging Cells

Other than adding text or changing individual cell properties, which are done using the Modify Text tool, table changes are made with the Edit Tool.

Note: For details on the Edit Tool,

\1. To start editing, activate the Edit Tool and click the table. You can move any of the nodes to change sizes of single rows or columns.

img

\2. To add a row or column, press Shift and click the cell to the left or above where the new item will go.

img

Note: If you want to Shift-select a new cell, you must first use Shift and click to de-select the current cell.

  1. Insert Row and Insert Column are available on the local menu or Inspector Bar.

img

The new row is added below the selected cell.

img

\4. To remove a row or column, Shift-select a cell in that row or column.

img

The row is removed.

img

\5. To merge cells, Shift-select each cell you want to merge.

img

\6. Select Merge Cells in the local menu or Inspector Bar.

img

The selected cells are now one cell.

img

\7. To separate them again, Shift-select the cell and select Unmerge.

Local Menu & Keyboard

The local menu provides additional controls and lists the complementary keyboard commands for those functions. You can change and expand or contract the cells which are selected. most importantly you can opt to edit the cells text or block. img

Insert Table

img

Default UI Menu: Draw/Table/Table

Ribbon UI Menu:

img

Before creating a table, you can define a table style. Styles are useful for creating tables with specific text properties, cell colors, and header / title rows.

img

To apply the style to the table, open the tool's Properties and select the style on the General page.

img

You can also change an existing table's style in is Properties, or in the Selection Info palette. There are two methods of inserting a table: Specify Insert Point and Specify Window.

Specify Insert Point

With this method, you click the top left point of the table.

\1. Make sure Specify Insert Point is selected in the local menu or Inspector Bar. The number of columns and rows, as well as column width and row lines (number of lines of text) is set in the Inspector Bar.

img

\2. Click once in the file, and the table is inserted.

img

\3. If you don't want to insert another table, press Esc or start a new tool.

\4. If you need to change the size of an individual row or column, use the Edit Tool.

Specify Window

With this method, you insert the table by clicking two corner points. You can either fix the cell dimensions, or you can fix the number of rows / columns. (You can also mix options for sizing and numbers for rows and columns.) Make sure Specify Window is selected in the local menu or Inspector Bar.

img

Fixed Number of Rows - Columns

\1. Activate both Calculated Row Height and Calculated Column width.

img

\2. Click once to set the top left corner of the table.

img

\3. Set the number of columns and rows.

img

\4. Move the mouse to size the table.

img

The number of cells remains the same, no matter how the table is sized.

img

\5. Click the second corner to insert the table. If you specified a table style, it will be applied.

img

\6. If you need to change the size of an individual row or column, use the Edit Tool.

Fixed Cell Size

\1. Turn off both Calculated Row Height and Calculated Column width.

img

\2. Click once to set the top left corner of the table.

img

\3. Set the column width and number of text lines per row.

img

\4. Move the mouse to size the table.

img

The cell size remains the same, no matter how the table is sized. Cells are added or removed as needed.

img

\5. Click the second corner to insert the table. If you specified a table style, it will be applied.

img

\6. If you need to change the size of an individual row or column, use the Edit Tool.

Modify Table

Default UI Menu: Draw/Table/Modify Table

Ribbon UI Menu:

img

Modify Table is used to add text to cells, or to edit existing cell text. It can also be used to change properties of individual cells.

Adding or Editing Cell Text

If you are using styles, the table style will refer to a text style for each type of text (data, header, and title). So unless you want to use standard text, define text styles first.

img

Note: For details on text styles,

Open the table style you want to use, and specify the text style you want to use for Data text. You can also set text color and height here.

img

There are also categories for Header and Title, which can each have their own text style.

img

\1. To add text to the table, activate Modify Table.

\2. Make sure Edit Cell Text is active in the local menu or Inspector Bar.

img

\3. Select the table you want to modify, then click in a cell where you want to place text.

img

\4. Click in each cell and select Edit Text from the Inspector bar or Local menu. Then type the text.If your drawing has blocks use Insert block you can also opt to insert a block into the cell.

img

\5. If you want to remove text from a cell, click it and select Clear Cell Content from the local menu or Inspector Bar.

img

\6. When the table text is complete, end Modify Text. The properties of the cell text will match their text styles.

img

Changing Cell Properties

\1. If you want to use Modify Text to change properties of an individual cell, make sure Edit Cell Text is not active.

img

\2. Click the cell you want to change.

img

\3. The properties of the cell can be changed in the Selection Info palette. In this example, the cell's fill color was changed.

img

\4. When finished, the cell has the new properties.

img

Text Rotation:

DoubleCAD table now supports the "Text Rotation" property. Now table cell has editable property - Text Rotation.

Also, cell editing has been improved. Now the cell selection in not lost after changing the properties of the cell using the "Selection Info Palette".

img

Table Export (*.xlsx)

Default UI Menu: Draw/Table/Table Export

Ribbon UI Menu:

img

This tool allows you to save a table as an Excel (.xlsx) file. To save a XLSX file:*

\1. Select the tool.

\2. Click on a table.

img

\3. Type in a File name.

img

\4. Click the Save button.

\5. Press the Space bar to finish.

Table Import (*.xlsx)

Default UI Menu: Draw/Table/Table Import

Ribbon UI Menu:

img

This tool enables you to create a table based on a sheet from an Excel (*.xlsx) File. To Create a Table:

Start the too and the dialog appears.

Click the down arrow in the Choose an Excel Data Link dropdown.

img

Click on Create New Data Link.

Type in a name and click OK.

img

Click the down arrow in the Choose an Excel file dropdown.

Click on Browse for a new Excel (*xslx) file.

img

Select a file.

Click Open.

Click the down arrow in the Select Excel sheet to link to dropdown.

img

Select a sheet.

img

Click OK.

Position the cursor and click to insert the table.

img

The dialog will reopen.

img

Change the parameters and insert another sheet, or click Cancel to terminate the operation.

To Delete a Data Link

  1. Click the down arrow in the Choose an Excel Data Link dropdown.
  2. Select an existing link.
  3. Click the Delete button.

(Available in XT Pro)

Default UI Menu: Tools/Palette/Database Connect

Ribbon UI Menu:

img

DoubleCAD has the ability to connect to a database and associate the data with objects. Database connectivity and management is handled through the Database Connection Palette.

img

To Create a Database Connection:

\1. Open the Database Connection Palette.

\2. Right click on the DataSources icon and click Add DataSource.

img

\3. In the Add Datasource dialog type in the name of the new datasource and click OK.

img

\4. The Data Link Properties dialog will open.

\5. On the Provider page select the appropriate OLE DB Provider type for the datasource to which you wish to connect. Then click Next.

img

\6. The Connection page will appear.

img

\7. Specify the database source. or

\8. Use connection String

​ 1. Click Build

img

​ 2. Select a File Data Source or Machine Data Source

img

img

​ 3. Set login info if needed, then press OK.

img

​ 4. Select the Database.

img

\9. Setup the Server login information.

\10. Click the Test Connection button. If the connection is valid the Test Connection Succeeded message will appear.

img

\11. At this point you can move on to the Advanced and All pages, or click OK.

\12. The features and functions of the Advanced and All pages are network and database specific, and are dependent upon your network and OBDC/OLE DB protocols. Only a person and experienced with your network and database protocols should alter these settings.

img

img

\13. After these operations you will see a new datasource object in DataSources tree.

img

\14. The datasource is not yet connected. Right-click on the datasource and select Connect.

img

\15. Your database is now connected to DoubleCAD as a datasource.

\16. When connected a datasource shows all available tables and views in database.

To Disconnect a Datasource:

  1. Select a connected datasource in the DataSources tree.

\2. Right-click on the datasource and select Disconnect.

img

To Re-configure a Datasource:

\1. Select a datasource in the DataSources tree.

\2. Right-click on the datasource and select Configure. This will open the Data Link Properties dialog.

img

\3. Make the required changes and click OK.

To Remove a Datasource:

\1. Select a datasource in the DataSources tree.

\2. Right-click on the datasource and select Remove DataSource.

img

\3. You will be prompted with a warning dialog.

\4. If you are clear to proceed click Yes.

To Export a Datasource:

\1. Select a datasource in the DataSources tree.

\2. Right-click on the datasource and select Export DataSource.

img

\3. This will open Save As dialog.

img

\4. Select a location and name for the datasource, and then click Save.

To Import a Datasource:

\1. Right click on the DataSources icon and click Import DataSource.

img

\2. This will start the Open dialog.

img

Note: Connect is only available when a datasource is disconnected. Disconnect is only available when a datasource is connected.

In order to connect data from tables to graphic objects it is necessary to create Link Templates. Link templates set a pattern that defines which the data elements will be linked from the table and associated with designated graphic objects. To Create a New Link Template:

\1. Select a table in the DataSources tree.

img

\2. Right-click and select New Link Template, or click the . The New Link Template dialog will appear.

img

\3. Type in a name for the link template, and then click OK.

img

\4. The Link Template Edit dialog will appear.

\5. Select the Key Columns. These are used to define link information data for linked graphics.

\6. Select the Value Columns. These values will be set as custom properties of the object.

\7. The created link template will be attached to current active drawing.

img

To Edit a Link Template:

\1. Select the template in the DataSources tree.

img

\2. Right-click and select Edit. The Link Template Edit dialog will appear.

img

\3. Make the required changes, and then click OK.

To Remove a Link Template:

\1. Select the template in the DataSources tree.

\2. Right-click and select Delete.

Warning: The link template will be immediately deleted. Removing a link template leads to removing all graphic links bound to it.

img

\3. You will be prompted to confirm the deletion.

Linking Data to Graphics

Data is linked to graphics by connecting a table to specific graphics via link templates. To Connect Data to Graphics:

\1. In a drawing, select one or more graphics.

img

\2. In the DataSources tree, double click on the desired table to select it for linking. This will also open the view of the table in the lower frame of the palette.

img

\3. In the table view, in the lower frame of the palette, click on the record you wish link.

img

\4. Use the Link Template drop-down box located on the palette toolbar to select the desired link template.

img

\5. Click the Create Link button on palette toolbar.

img

\6. The link between the selected graphics and the table record is created.

\7. Go to the Custom Properties of the object to verify the link.

img

Synchronizing Data and Graphics

To get data into linked graphics it is necessary to synchronize the data. The synchronizing process copies data from the datasource into all linked graphics and places it in the custom properties of linked graphics. To Synchronize Data:

\1. Click the Synchronize Data button on toolbar to run synchronizing process.

img

\2. Verify that the data has been synchronized by opening the properties of a graphic that is linked and going to the Custom page.

img

To Remove Links from Selected Graphics:

\1. Select the graphic/s you wish to de-link.

\2. In the DataSources tree select the link template you wish to de-link from the graphic/s.

img

\3. Right-click and select Delete Links(Sel).

img

\4. Synchronize the data.

\5. The links and data have been removed.

To Remove All Links to a Link Template:

\1. In the DataSources tree select the link template you wish to de-link.

img

\2. Right-click and select Delete All Links.

img

\3. Synchronize the data.

\4. The links and data have been removed.

To Find Graphics Linked to the Datasource:

\1. Select the datasource.

\2. Click the View linked objects in drawing button on palette's toolbar.

\3. Right-click and select Find Graphics.

img

To Find Table Record Linked to a Selected Graphics:

\1. Select a graphic.

\2. Click the View linked records in dataview button on palette's toolbar.

img

\3. All records which are linked to the selected object will be highlighted in the table view.

img

Viewing and Editing Data in Tables

When connected a datasource shows all available tables and views in database. Available tables and views appear as child nodes of the datasource.

img

To Show a Table's Content:

  1. Select the table in the DataSources tree.
  2. Right-click and select View Table, the table will be opened in the lower frame of the Data base Connection palette in Read-Only mode.

img

To Edit a Table's Content:

  1. Select the table in the DataSources tree.
  2. Right-click and select Edit Table, the table will be opened in the lower frame of the Data Base Connection palette in Edit mode.

img

(Available in XT Pro)

Default UI Menu: Tools/Database

Ribbon UI Menu:

img

All properties of objects are elements of a database. Standard database property items include line width, color, coordinates of points that comprise the object, etc. The database management feature enables you to add information to objects and to create reports using this information. For example, you can add custom fields to provide information on suppliers, manufacturers, price, etc. The information can then be presented as a Bill of Materials, Parts List, or other type of report. Database management and report creation generally follows these four steps:

  • Step 1: Define Custom Fields
  • Step 2: Attach Custom Properties to Objects
  • Step 3: Define Fields for the Report
  • Step 4: Create the Report

The following example shows how to create some custom properties, then create a report from the custom and standard properties. The objects in the report are shown below: a large plastic disc, two cubes on top, and six steel cylinders below. img

Step 1- Define Custom Fields

Default UI Menu: Tools/Database/Define Fields

Ribbon UI Menu:

img

The first step in creating a database is to define the types of information to be recorded.

\1. Select Define Fields. In the DefineFields window, enter the first property: "Part Number."

img

\2. Fill in the remaining fields in this row

img

Data Type: Text: Alphanumeric information which does not have to be calculated. Integer: Whole numbers. Double: Decimal numbers. Currency: Dollar amounts. This type will not appear in an object's Custom page of the Properties window. Visible: If checked, the field will be visible and available for use in the Edit Object Data and Report windows.

Tip: If you know you will not be using certain fields in reports, it is helpful to turn off visibility.

Editable: If checked, the field can be edited in the other database dialogs. Auto fields are always non-editable. Description: An optional field for notes or other comments.

\3. To add the next property to the database, click in the first empty field under Field Name, and type the new field name. This example uses "Description," Vendor," and "Cost." Then continue to fill in the other fields.

img

Note: To delete a record, click the square at the beginning of a row, and select Delete.

\4. Click OK when the custom properties are defined.

Step 2- Attach Custom Properties to Objects

\1. Select the object whose custom properties you want to define. If multiple objects have the same custom properties, such as the cubes below, select them all.

img

\2. Open the Properties to the Custom page. Click Attach at the bottom of the window.

img

\3. Select all of the custom properties and click OK.

img

\4. Now the properties appear on the Custom page. Fill in the Value for each part.

img

You can also enter or change custom properties in the Selection Info palette.

img

\5. The previous values were for the two cubes (Part Number 1); the values below are for the large disc (Part Number 2).

img

\6. These values are for the six support cylinders (Part Number 3).

img

\7. To verify that the custom properties were properly attached, select one of the objects.

img

\8. Then select Tools / Database / Edit Object Data. You can update values in this table, if needed.

img

Step 3- Define Fields for the Report

Default UI Menu: Tools/Database/Report

Ribbon UI Menu:

img

\1. To begin defining the report, select Tools / Database / Report. Then click Create.

img

\2. Enter a report Title and Comments (optional). If you choose Detail, only values from editable fields may be edited before the report is created. With Summary, all values may be edited before printing, even if they come from a non-editable field.

img

Note: "Object ID" is a unique identifier, and is generated automatically when attaching fields to objects.

\3. The custom fields appear under the "Custom" category. Click the "plus" sign to expand this category.

img

\4. For each field you want to appear in the report, click it under Available Fields, then click the Add button. The field should then appear under Report Fields. Repeat these steps for each of the custom fields.

img

Note: If you have block in your drawing with attributes you can add those attributes to your report.

\5. Non-custom (standard) fields can also be added to a report. In this example Material is added, and Material is found in the "Common" category.

img

You do not have to create a report using custom fields; reports may contain only standard fields.

\6. The order of the Report Fields list is the order that will in the report. To change the order, highlight the field you want to move and click Up or Down. (You will also be able to change the order later.)

img

\7. You can use a query if you want to filter the objects to be included in the report. If you want to run a query, click Edit. Otherwise, all objects in the model will be scanned while creating the report.

img

An example of a query in this example would be to search for objects that have "Part Number" fields greater than one. This is how the syntax would look:

img

\8. If you created a query, click OK to return to the Report Create window.

Note: For details on query searches,

\9. Open the Advanced Report table.

img

The appearance of this tab depends on whether you are creating a Detail or Summary report. For a Detail report, Field Names can be edited. For a Summary report, Report Header Names may be edited.

\10. For the "Copy" row, click the cell in the Function column. From the drop-down menu, select SUM. This will show the total cost of all objects, not the unit price per object.

img

The other function options are AVG which calculates the average of all values, and MIN / MAX which displays the smallest or largest of the values.

\11. When all fields and queries are defined, click OK to return to the Reports window.

img

Step 4- Create the Report

Default UI Menu: Tools/Database/Report

Ribbon UI Menu: